Обход блокировки для NAS4Free

Страницы :   Пред.  1, 2, 3  След.

Ответить
Автор
Сообщение

Славо4ек

Помощник модератора

Стаж: 8 лет 8 месяцев

Сообщений: 2230

Славо4ек · 19-Окт-17 14:01 (11 месяцев назад)

[Цитировать] 

hlid111
я понимаю надо тот, что прописан в сеть/управление интерфейсами
[Профиль]  [ЛС] 

Floogleblazz

Стаж: 9 лет 8 месяцев

Сообщений: 98

Floogleblazz · 19-Окт-17 21:40 (спустя 7 часов, ред. 19-Окт-17 21:40)

[Цитировать] 

рановато я обрадовался
перезагрузку не переживает, нужно опять удалять tor и privoxy
потом можно перезагрузить и скрипт заново все установит и запустит.
как я понял не переживают перезагрузку группы _tor и privoxy,
если посмотреть (Доступ > Пользователи > группы ) то их там нет.
и второй непонятный момент,
зеленеют раздачи только с анонсером http://bt4.t-ru.org/ann
хотя в первый раз все работали.
вот сижу размышляю
p/s bt3.t-ru.org/ann раздачи тоже зеленые
p/p/s после очередной переустановки тор и privoxy
все анонсеры работают, все раздачи зеленые
[Профиль]  [ЛС] 

Славо4ек

Помощник модератора

Стаж: 8 лет 8 месяцев

Сообщений: 2230

Славо4ек · 20-Окт-17 02:22 (спустя 4 часа, ред. 20-Окт-17 02:22)

[Цитировать] 

Embedded на виртуалке победил пока
нагрёб правда всякого, мб и лишнего
акромя
В sysctl.conf добавить
Код:
net.inet.ip.random_id=1

ещё В rc.conf
Код:
firewall_enable="YES"
firewall_type="/etc/rc.firewall"
firewall_script="/etc/rc.firewall"
и разок это использовал
Посмотреть какие модули загружены:
kldstat
если нету ipfw.co
загрузить kldload ipfw
и добавить в загрузку при старте системы в /boot/loader.conf

последнюю строку не делал!
кто умней да помоложе - "нарисуйте" внятную инструкцию, просим!
[Профиль]  [ЛС] 

Sonyz

Стаж: 9 лет 1 месяц

Сообщений: 1


Sonyz · 20-Окт-17 10:35 (спустя 8 часов, ред. 20-Окт-17 16:58)

[Цитировать] 

Славо4ек писал(а):
кто умней да помоложе - "нарисуйте" внятную инструкцию, просим!
Поддерживаю просьбу!
[Профиль]  [ЛС] 

hharn

Стаж: 9 лет 9 месяцев

Сообщений: 3


hharn · 20-Окт-17 17:49 (спустя 7 часов)

[Цитировать] 

После выполнения инструкций - часть раздач позеленело. Но остались и красные раздачи - при этом уже новая ошибка:
Tracker gave HTTP response code 503 (Service Unavailable).
[Профиль]  [ЛС] 

Floogleblazz

Стаж: 9 лет 8 месяцев

Сообщений: 98

Floogleblazz · 20-Окт-17 23:04 (спустя 5 часов)

[Цитировать] 

hharn писал(а):
74055193После выполнения инструкций - часть раздач позеленело. Но остались и красные раздачи - при этом уже новая ошибка:
Tracker gave HTTP response code 503 (Service Unavailable).
такая же фигня,
часто помогает остановить раздачу и опять включить
[Профиль]  [ЛС] 

Славо4ек

Помощник модератора

Стаж: 8 лет 8 месяцев

Сообщений: 2230

Славо4ек · 21-Окт-17 14:56 (спустя 15 часов, ред. 21-Окт-17 14:56)

[Цитировать] 

Tracker gave HTTP response code 503 (Service Unavailable)
при большом количестве раздач это бывает - должно обновляться потихоньку
добился срабатывания на фулл-системе, но...
при перезагрузке слетают пользователи и группы - привокси и тор
как это исправить?
сложный вариант - при запуске скрипт на удаление и установку, но может проще можно?
кодеры, помогите!
а пока в такой версии для Full
Содержимое файла tor_privoxy.sh:
Код:
#!/bin/sh
# Transmission http anoncer fwd
pkg delet -y tor
pkg delet -y privoxy
pkg install -y tor
pkg install -y privoxy
mv /usr/local/etc/tor/torrc /usr/local/etc/tor/torrc.sample
cp /mnt/[color=red]имя_пула[/color]/torrc /usr/local/etc/tor/
cp /mnt/[color=red]имя_пула[/color]/config /usr/local/etc/privoxy/
service tor onestart
service privoxy onestart
kldload ipfw
ipfw add 01110 fwd 127.0.0.1,8118 tcp from any to any 80 not uid privoxy out via em0
em0 - для сетевого моста на виртуалке
[Профиль]  [ЛС] 

[email protected]

Стаж: 8 лет 10 месяцев

Сообщений: 7


[email protected] · 22-Окт-17 22:38 (спустя 1 день 7 часов)

[Цитировать] 

Огромное спасибо! И у меня всё заработало!
С небольшой оговоркой правда, но всё же...
Повторил ещё раз все действия из инструкции sanrega с дополнениями от Floogleblazz, и всё взлетело!
Единственное, торренты так и остались красными, и в группах/пользователях не появились упомянутые Floogleblazz _tor и privoxy.
Ошибка не изменилась: could not connect to tracker. Но не смотря на это исправно работает загрузка и отдача. Раньше не было и этого.
hlid111 писал(а):
74044708А тут железячный надо интерфейс? Просто у меня он re0, а bge0 не мост ли?
Пробовал ставить и re0, и bge0. Не заметил разницы. Работает и так, и так. У меня тоже указано re0 (состояние > интерфейсы).
[Профиль]  [ЛС] 

Floogleblazz

Стаж: 9 лет 8 месяцев

Сообщений: 98

Floogleblazz · 23-Окт-17 18:48 (спустя 20 часов)

[Цитировать] 

[email protected]
попробуйте удалить tor и privoxy и установить снова, для этого
отредактируйте tor_privoxy.sh как рекомендовал Славо4ек
( добавьте:
pkg delet -y tor
pkg delet -y privoxy )
и перезагрузите NAS
мне кажется раздачи должны позеленеть.
[Профиль]  [ЛС] 

hlid111

Стаж: 11 лет 8 месяцев

Сообщений: 30

hlid111 · 23-Окт-17 20:39 (спустя 1 час 51 мин.)

[Цитировать] 

Floogleblazz писал(а):
74076263[email protected]
попробуйте удалить tor и privoxy и установить снова, для этого
отредактируйте tor_privoxy.sh как рекомендовал Славо4ек
( добавьте:
pkg delet -y tor
pkg delet -y privoxy )
и перезагрузите NAS
мне кажется раздачи должны позеленеть.
delete, наверное
[Профиль]  [ЛС] 

Славо4ек

Помощник модератора

Стаж: 8 лет 8 месяцев

Сообщений: 2230

Славо4ек · 23-Окт-17 23:48 (спустя 3 часа)

[Цитировать] 

Код:
pkg delet _имя порта_
ключ -y я так понимаю ключ для тихого режима "йес" якобы
[Профиль]  [ЛС] 

Floogleblazz

Стаж: 9 лет 8 месяцев

Сообщений: 98

Floogleblazz · 25-Окт-17 19:56 (спустя 1 день 20 часов, ред. 25-Окт-17 19:56)

[Цитировать] 

hlid111 писал(а):
74077063...
delete, наверное
у меня delet работает
привожу свой файл:
Код:
#!/bin/sh
# Transmission http anoncer fwd
pkg delet -y tor
pkg delet -y privoxy
pkg install -y tor
pkg install -y privoxy
mv /usr/local/etc/tor/torrc /usr/local/etc/tor/torrc.sample
cp /mnt/system/Rutr/torrc /usr/local/etc/tor/
cp /mnt/system/Rutr/config /usr/local/etc/privoxy/
service tor onestart
service privoxy onestart
ipfw add 01110 fwd 127.0.0.1,8118 tcp from any to any 80 not uid privoxy out via em0
[Профиль]  [ЛС] 

Славо4ек

Помощник модератора

Стаж: 8 лет 8 месяцев

Сообщений: 2230

Славо4ек · 26-Окт-17 02:07 (спустя 6 часов, ред. 26-Окт-17 02:07)

[Цитировать] 

Floogleblazz
а где же kldload ipfw?
он у Вас перезагрузку переживает?
[Профиль]  [ЛС] 

Floogleblazz

Стаж: 9 лет 8 месяцев

Сообщений: 98

Floogleblazz · 26-Окт-17 22:50 (спустя 20 часов)

[Цитировать] 

Славо4ек
честно не понимаю,
и так и так работает одинаково.
[Профиль]  [ЛС] 

[email protected]

Стаж: 8 лет 10 месяцев

Сообщений: 7


[email protected] · 28-Окт-17 01:20 (спустя 1 день 2 часа, ред. 28-Окт-17 01:20)

[Цитировать] 

Floogleblazz писал(а):
74076263[email protected]
попробуйте удалить tor и privoxy и установить снова, для этого
отредактируйте tor_privoxy.sh как рекомендовал Славо4ек
( добавьте:
pkg delet -y tor
pkg delet -y privoxy )
и перезагрузите NAS
мне кажется раздачи должны позеленеть.
Всё сделал по инструкции, но всё равно ничего не изменилось. Пробовал с "delet" и с "delete". Торренты так и остались красными.
Задам ряд глупых вопросов, может я чего-то не понимаю, и проблема лежит совсем на поверхности:
-Может быть потому что у меня embedded версия, а не full?
-Может это быть из-за устаревшей версии системы (10.3.0.3 x86, Pilingitam)
-Нужно ли для работы системы давать дополнительно права на папку с файлами скрипта? По моей логике не нужно, т.к. обращение к файлам идёт от имени системы, но на всякий случай дал 777. Пути все те же, как и в вашем коде.
Более того, сейчас торренты вообще не работают. Хотя пару дней назад всё было в порядке, и перезагрузки с тех пор не было. Чертовщина какая-то...
[Профиль]  [ЛС] 

Floogleblazz

Стаж: 9 лет 8 месяцев

Сообщений: 98

Floogleblazz · 28-Окт-17 18:23 (спустя 17 часов)

[Цитировать] 

[email protected]
Доступ > Пользователи и Группы > Группы
в списке есть группы _tor и privoxy ?
если нет, то и tor и privoxy не запустятся
[Профиль]  [ЛС] 

ni5moGT

Стаж: 10 лет 1 месяц

Сообщений: 9

ni5moGT · 29-Окт-17 21:25 (спустя 1 день 3 часа, ред. 30-Окт-17 08:16)

[Цитировать] 

Все поставил, конфиги есть, запущено и работает.
Правило ipfw настроил.
При запросе на rutracker.org через curl (если указать прокси):
Код:
curl -x http://127.0.0.1:8118 bt3.t-ru.org/ann
Дает 200 OK
При таком же запросе без указания прокси:
Код:
curl --verbose  bt3.t-ru.org/ann
Дает 400 Invalid header received from client
Т.е. сервисы работают, но проблема в перенаправлении запросов.
Подскажите, как решить?
Код:
> ipfw show
01110     150      12631 fwd 127.0.0.1,8118 tcp from any to any dst-port 80 not uid privoxy out via epair0b
65535 7445773 7480543926 allow ip from any to any
UPD
Проблема решена.
Просмотрел опцию в конфиге privoxy
Код:
tolerate-pipelining 1
Без нее перенаправление через ipfw не работает.
[Профиль]  [ЛС] 

[email protected]

Стаж: 8 лет 10 месяцев

Сообщений: 7


[email protected] · 30-Окт-17 00:48 (спустя 3 часа, ред. 30-Окт-17 00:48)

[Цитировать] 

Floogleblazz
Дело в том, что у меня абсолютно отсутствует понимание, что есть эти tor b privoxy.
Я был уверен, что группы будут созданы автоматически, после установки этих самых пакетов.
Сейчас создал группы ручками, перезагрузился, но ничего не изменилось. Торренты по прежнему красные.
Задам ещё более нубский вопрос:
-Пути, прописываемые в privoxy куда должны вести? Я прописал только пути к torrc и config, которые лежат в пуле. Остальные не трогал, и в моём понимании, они по умолчанию должны стать актуальными, после установки tor и privoxy. На данный момент у меня их не существует.
Иначе говоря, пути "/usr/local/etc/privoxy/ /usr/local/etc/tor/ /usr/local/etc/tor/torrc.sample /usr/local/etc/tor/torrc" никуда не ведут, и папок таких не существует.
Весь файл выглядит вот так:
Код:
#!/bin/sh
# Transmission http anoncer fwd
pkg delet -y tor
pkg delet -y privoxy
pkg install -y tor
pkg install -y privoxy
mv /usr/local/etc/tor/torrc /usr/local/etc/tor/torrc.sample
cp /mnt/zfs-pool1/System/Rutr/torrc /usr/local/etc/tor/
cp /mnt/zfs-pool1/System/Rutr/config /usr/local/etc/privoxy/
service tor onestart
service privoxy onestart
kldload ipfw
ipfw add 01110 fwd 127.0.0.1,8118 tcp from any to any 80 not uid privoxy out via re0
В командных скриптах прописан запуск tor_privoxy.sh, постинициализация, но галочка "включить" как на скрине отсутствует в принципе. Я так понимаю, это из-за версии nas4free.
[Профиль]  [ЛС] 

Floogleblazz

Стаж: 9 лет 8 месяцев

Сообщений: 98

Floogleblazz · 30-Окт-17 22:06 (спустя 21 час)

[Цитировать] 

[email protected]
ну тут многие не понимают, включая меня) но когда это останавливало))
после перезагрузки nas если зайти в журнал
Диагностика > Журнал
после записи:
pkg: tor-0.3.1.7 installed
есть какие-нибудь ошибки?
[Профиль]  [ЛС] 

[email protected]

Стаж: 8 лет 10 месяцев

Сообщений: 7


[email protected] · 02-Ноя-17 02:32 (спустя 2 дня 4 часа)

[Цитировать] 

Floogleblazz писал(а):
74125158[email protected]
ну тут многие не понимают, включая меня) но когда это останавливало))
после перезагрузки nas если зайти в журнал
Диагностика > Журнал
после записи:
pkg: tor-0.3.1.7 installed
есть какие-нибудь ошибки?
Я наверное Вас сейчас крайне удивлю, но нет такой записи. Посмотрел поиском по ключевым словам "install" и "pkg". Нет вообще ничего подобного. Первая мысль - не стартует автозапуск скрипта, и может быть что-то не так прописано в запуске. Перепроверил всё несколько раз, вроде бы всё верно. У меня почему-то галочки включить нет, как на скринах, на первой странице темы, может быть в этом дело? Скриншоты под спойлером.
скрытый текст


[Профиль]  [ЛС] 

sagem830

Top Bonus 05* 10TB

Стаж: 11 лет 1 месяц

Сообщений: 30

sagem830 · 03-Ноя-17 16:00 (спустя 1 день 13 часов, ред. 03-Ноя-17 16:00)

[Цитировать] 

Здравствуйте. Вчера переехал на сборку n4f 11.1.0.4 - Atomics (сборка 4812). Проверил - все автоматом поднялось и работает.
Только долго ставится privoxy, тянет зависимости.
Проверять перепост лень, исходники здесь:
http://forum.ixbt.com/topic.cgi?id=109:309:5447#5447
http://forum.ixbt.com/topic.cgi?id=109:309:5449#5449
http://forum.ixbt.com/topic.cgi?id=109:309:5452#5452
Из неочевидного: файлам конфигов и скрипта назначен владелец root:wheel, права 755, скрипт помечен как исполняемый.
Последнюю пару дней до половины раздач висят красные с Tracker gave HTTP response code 503 (Service Unavailable), но это уже вопрос скорости ТОР и восприятия трекера.
P.S. скрипт и конфиги изначально собирались и тестились на компе с i5 и 32ГБ памяти, на слабых конфигах возможны проблемы (было в виртуалке); и только для embedded-версии
[Профиль]  [ЛС] 

jinlipu301

Стаж: 7 лет 3 месяца

Сообщений: 1


jinlipu301 · 05-Ноя-17 18:33 (спустя 2 дня 2 часа)

[Цитировать] 

У меня все позеленело так:
1) выполнил все инструкции из шапки + перезагрузка
2) подключился к SSH консоли (через putty) и выполнил каждую команду(строчку) скрипта tor_privoxy.sh в ручную
3)....
4) profit
[Профиль]  [ЛС] 

Славо4ек

Помощник модератора

Стаж: 8 лет 8 месяцев

Сообщений: 2230

Славо4ек · 09-Ноя-17 20:29 (спустя 4 дня)

[Цитировать] 

jinlipu301
и что после ребута?
[Профиль]  [ЛС] 

sagem830

Top Bonus 05* 10TB

Стаж: 11 лет 1 месяц

Сообщений: 30

sagem830 · 12-Дек-17 11:31 (спустя 1 месяц 2 дня)

[Цитировать] 

Замечено подвисание privoxy при долговременной работе. Выражается в покраснении раздач.
Причин пока не нашел.
Временный костыль:
- запустить команду "service privoxy onestop"
- подождать (у меня достаточно 10-20 сек.)
- запустить команду "service privoxy onestart"
[Профиль]  [ЛС] 

hassel

Стаж: 9 лет 10 месяцев

Сообщений: 1


hassel · 17-Дек-17 06:59 (спустя 4 дня)

[Цитировать] 

Некоторое время всё работало, но некоторое время назад все раздачи опять
покраснели. Судя по всему не запускается tor. Есть подозрение, что проапдейтился
tor в репозитории
service tor onestart
Starting tor.
/usr/local/bin/tor: Undefined symbol "timingsafe_memcmp"
/usr/local/etc/rc.d/tor: WARNING: failed to start tor
Куда пинать?
[Профиль]  [ЛС] 

sagem830

Top Bonus 05* 10TB

Стаж: 11 лет 1 месяц

Сообщений: 30

sagem830 · 22-Дек-17 07:20 (спустя 5 дней)

[Цитировать] 

Попробуйте проверить память.
У меня большие аптаймы, планово смогу запустить перезагрузку только в новом году.
[Профиль]  [ЛС] 

Славо4ек

Помощник модератора

Стаж: 8 лет 8 месяцев

Сообщений: 2230

Славо4ек · 22-Дек-17 11:00 (спустя 3 часа, ред. 08-Фев-18 13:23)

[Цитировать] 

пробовал с целью улучшения работы приоритет двум рассматриваемым процессам "приподнять" - немножко помогло, но в результате "уронил" систему. после двух-трёх недель работы, печально
[Профиль]  [ЛС] 

sagem830

Top Bonus 05* 10TB

Стаж: 11 лет 1 месяц

Сообщений: 30

sagem830 · 31-Дек-17 13:40 (спустя 9 дней)

[Цитировать] 

hassel
Ребутился - все нормально поднялось. Проверяйте память.
[Профиль]  [ЛС] 

Lord_Nefarius

Хранитель

Стаж: 9 лет 5 месяцев

Сообщений: 24

Lord_Nefarius · 25-Фев-18 07:35 (спустя 1 месяц 24 дня, ред. 01-Апр-18 02:59)

[Цитировать] 

У меня возникла довольно странная проблема,
http://bt2.t-ru.org:80
Announce error: Tracker gave HTTP response code 400 (Bad Request) - Today 07:20:41 AM
Next announce in 5 minutes
Last Scrape: N/A
Все инструкции выше выполнил, результат отсутствует
UPD 01.05.2018 2:57 В итоге плюнул на этот способ, обошел через роутер http://rutracker.org/forum/viewtopic.php?t=5392032
[Профиль]  [ЛС] 

bevb

Стаж: 8 лет

Сообщений: 22


bevb · 12-Апр-18 20:08 (спустя 1 месяц 15 дней)

[Цитировать] 

какие правила прописать ipfw чтобы заработало перенаправление на прокси blockme ?
[Профиль]  [ЛС] 
 
Ответить
Loading...
Error